SYSTEM REQUIREMENTS

PHP
PHP version 5.6.x is one of the essential requirements to run this script.
MySQL server
MySQL version 5.0 or later
(we recommend the very latest stable release)
PHP Decoders

Portions of the Script code are encoded and require a PHP decoder in order to run. You can download if from following link.

Download ionCube Loader

Server

Any web server daemon - such as Apache, nginx, IIS which is fully compatible with the required PHP configuration.

  • Operating System - Solaris, Linux, BSD, Windows or Mac
  • Drush
  • GD complied with your PHP Build - Yes
  • PHP safe mode - OFF
  • The PHP function file_get_content() to be enabled
  • PHP memory_limit - 1024M
  • PHP CURL - Yes
  • Minimum Web Space - 1 GB
Optional Server Requirements

The requirements listed below are only required if you decide to use one of the following optional modules.

  • Video Module
  • Music Module
    • PHP file_uploads - 1
    • PHP post_max_size - 10M
    • PHP max_input_time - -1
    • PHP upload_max_filesize - 20M
  • Short URL
    • mod_rewrite (Apache)
  • Facebook Connect
PHP Settings
  • session.cache_limiter = nocache
  • session.auto_start = 0
  • expose_php = off
  • allow_url_fopen = off
  • magic_quotes_gpc = off
  • register_globals = off
  • display_errors = Off
  • max_execution_time = 120
Required PHP Modules
  • date
  • dom
  • filter
  • gd
  • hash
  • json
  • pcre
  • pdo
  • session
  • SimpleXML
  • SPL
  • xml
Apache server settings

If you have mod_security installed on your apache web server, mod_security must be disabled or your Script files whitelisted (exempt from all mod_security rules).

  • sql_mode : not strict
PHP cache and accelerators
It is highly recommended that caching be enabled under admin/config/development/performance. This will help increase the performance of your b2b script and the end user experience.
Web Browser Requirements
The requirements for a web browser depends on what theme you are using for your site. The default theme we release has been tested to work on the latest versions of all the most common web browsers (eg. Firefox, IE8, Opera, Chrome etc...). For those that use Internet Explorer must have version 7 or higher installed in order to properly use all the features provided with v2.
How to check your hosting provider meets these requirements



1. Ask your host. The best way to check your requirements is to simply contact your host and ask them. Simply link them back to this page so they can look over the list.

2. You can also download our test script here. The zip package will need to upload that PHP file to your server and run it.
Need a host?



If you are having a hard time finding a host that meets the requirements give our recommended Hosting Service a try.